SPORTS

MSD Charge FI
for Kawasaki, Teryx 750 FIi
PN 4244
Note: The MSD Charge Enhancer is designed for 2009 and 2010 Kawasaki Teryx with electronic fuel
injection.
Parts Included:
1 - Charge FI Controller 1 -MSD View CD 1 - Micro-USB Cable

WARNING: When installing the Charge Fl, disconnect the battery cables. When disconnecting,
always remove the negative cable first and re-install it last.

WARNING: The Charge Fl controller is a performance device that allows the vehicle or engine to operate]
atincreased power and speed. Follow all OEM safety recommendations and use extra care

when operating at increased power and speed.

CAUTION: The Charge FI Controller will raise the maximum rev/speed limit of the engine. Note
that factory components may not be designed for the increase in rpm and may require
modifications to achieve the best performance and durability.

IMPORTANT: There is a possibility of oil accumulation
in the intake system when the factory
rpm limiter is exceeded. A visible sign
is smoke exiting the exhaust system.
There may be upgrades needed to
the stock crankcase breather system
to prevent this from occurring. Please
check with your UTV parts supplier for
oil catch can kits.

INSTALLATION
The Charge Flis designed with factory connectors for

easy installation. The housing is sealed for durability [ &
and under seat mounting. — — W

Figure 1 OEM ECU Location.

1. Remove the driver’s seat.

FACTORY
2. Locate and disconnect the OEM ECU (Figure 1). ECU -

3. Connect the factory harness to the MSD Charge
FI ECU (Figure 2).

4. Connect the MSD 26-pin and 18-pin connectors
to the OEM ECU (Figure 2).

5. Secure the MSD in place and reinstall the driver’s
seat.

Figure 2 Connect the MSD In-line.

MSD POWERSPORTS - wWww.MSDPOWERSPORTS.COM - (915) 858-3365 - FAX (915) 858-3496



2 INSTALLATION INSTRUCTIONS

MSDVIEW SOFTWARE INSTALLATION

Minimum requirements to install and run the MSDView software:

* Microsoft Windows XP/Vista

* Keyboard and Mouse or some other compatible pointing device.
* Available USB port.

* .NET 2.0 or wide band internet access for the .NET 2.0 installation.

Important: Exit all programs before installing the MSDView software.
Note: Install the MSDView software before connecting the MSD product.

1. Insert the MSD CD into your PC. The software will automatically begin the installation feature. If the
“autorun” feature is disabled on your PC, go to: Start and select Run, Select your CD Drive, and click
on the Setup .exe file. The MSDView wizard will walk you through the setup.

If the .NET Framework is not installed on your PC, the MSDView software will prompt the download and
setup. Click “Accept” to begin the update and follow the steps. (This requires an internet connection).
Depending on Internet speed, it may take awhile to download and install .NET.

Found New Hardware Wizard

FIRST TIME CONNECTION
1. Connect the MSD to the PC with the supplied USB
cable.

Welcome to the Found New
Hardware Wizard

This wizard helps you install software for:

Communications Fort

Note: The first time the MSD is connected to your
PC it will perform a new hardware installation
(Figure 3).

Z:') If your hardware came with an installation CD
“&2 or floppy disk. insert it now.

2. The Wizard will detect the Com Port and install the
required files. This may take a few minutes.

‘what do you want the wizard to da?

(%) Install the software automatically [Fecommended)
() Install from a list or specific location [@dvanced)

Click, Mext bo continue.

3. The Hardware installation window will stop the

setup to alert you about the installation. Click
“Continue Anyway” and the “Finish” to complete

the installation (Figure 4). Figure 3 Hardware Wizard.

Please wait while the wizard installs the software...
Hardware Installation

L '_‘ The software you are installing for this hardware:
.

Communications Port

haz nat paszed Windows Logo testing to verify its campatibility

with ‘Windows P, [T ell me why this testing iz important. )

i your i llation of this sof may impair
or destabilize the cormrect operation of your system
either immediately or in the future. Microzoft strongly
recommends that you stop this installation now and

tact the h vendor for that has
passed Windows Logo testing.

[ Continue Angway ] [ STOP Installation ]

Figure 4 Windows Alert.
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INSTALLATION INSTRUCTIONS 3
MSDVIEW SCREEN

When the MSDView software is run, a ‘Connect

screen’ will show all MSD products the software
can work with. Select PN 4244 and click connect

(Figure 5) | Part Mumnber Senial Mumber Corn Part

TUNING TABS
The 10-position rotary dial allows you to select from
10 preset tunes (Figure 6).

Select the desired TUNE tab to view or modify the
corresponding TUNE.

Note: The rotary dial will select the TUNE that controls
the engine. The heading of the selected TUNE
tab is green.

Figure 5 MSDView Connect Screen.

[=e

Filg  Edit Connect  Wiew Help

aEmERDOD TABS

TUNED || TUNET | TunEZ | TUNES | TUNES | TunEs | Tunes | Tune? | Tunes | TUNES
SETTINGS | ADYANCE | FUEL |

| TUNE4: ADVANCE: DEG
ENGINE SPEED 0 RPM WEHICLE SPEED

GREEN HEADING 1000 2000 3000 4000 S00D 6000 7000 | 8000 8000 | 10000 ;Z?NESPEED
SHOWS WHICH : N

TPS

TUNE IS ACTIVE IN ; o | oo oane | TENIS
THE MSD, BATTERY 0.1 [ vOLTS

LY lnﬂ COOLANT TEMPERATURE 302 | DEGF
-\p FUEL TRIM 00 | %

TIMING ADYANCE 0.0 | DEGREES
FUEL DUTY 0| %

F

Monitor

MHame

sBuag apiH

a

MAP 16 PSIA

4

Hide Setup

Name

TUNE

WEHICLE SPEED
ENGINE SPEED
MaP

TPS

ENGINE TIMING
BATTERY
COOLANT TEMPERATURE
FUEL TRIM
TIMING ADYVANCE
FUEL DUTY

\J

GREEN BALL
SHOWS REAL TIME

SHOWS REAL Tih MSDVIEW SCREEN
PERFORMANCE.

|| E|E|E|E|€E|E|E | €| E

COML COM3S Connected 4244 Teryx Charge Sn108 COM3S 4244 Teryx Charge Sn108

Figure 6 MSDView Window.
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() INSTALLATION INSTRUCTIONS

SETTINGS TAB

Engine Speed Limit: Allows the user to set the
maximum engine speed. Adjustable from 2,000 RPM
to 10,000 RPM.

Function

Engine Speed Limit

Yehicle Speed Limit

Vehicle Speed Limit: Allows the user to set the
maximum vehicle speed. Adjustable from 12 mph

Rear Cylinder Fuel Offset

to 124 mph.

Rear Cylinder Fuel Offset: Offsets the rear cylinder
by a percentage. Adjustable from -10% to 10%.

Read Cylinder Timing Offset: Offsets the timing
of the rear cylinder from -10° to 10° advanced
(Figure 7).

Read Cylinder Timing Offset

Figure 7 Settings Tah.

ADVANCE TAB
The Advance table controls the amount of ignition
timing advance to be added to OEM timing.

The custom tune is made by editing the cells in the
MAP vs Engine Speed table.

MAP 1.6 PSIA

Cell values range from -30° to 30°.

The green ball provides a real time view of the engine
speed vs MAP (Figure 8).

ENGINE SPEED O RPM

1000 2000 3000 @ 4000 @ S000 | GO0D0 | 7000 | 8OO0 | 9000 10000

145 o o o o o o o o o 0

134 o o o o o o o o o 0

116 o o o o o o o o o 0

102 o o o o o o o o o ]

87 o o o o o o o o o 0

73 o o o o o o o o o 0

58 o o o o o o o o o 0

4.4 o o o o o o o o o ]

29 o o o o o o o o o 0

LI -1 o o o DnD o o o 0

X GREEN BALL INDICATES THE REAL
TIME ENGINE PARAMETERS.

Figure 8 Advance Table.

FUEL TAB

The Fuel table controls the injector pulse width by
editing the cells in the TPS % vs. Engine Speed table.
Cell values range from -50% to 80% (Figure 9).

ENGINE SPEED D RPM

1000 2000 @ 3000 @ 4000 @ S000 @ 6000 | 7OOO | BOOO | SO00 @ 10000

Figure 9 Fuel Table.
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INSTALLATION INSTRUCTIONS 5
MONITOR Mame Walue Units
The Monitor Tab displays item readings in real time (Figure 10). W e 0 | Selesed
Tune: Rotary dial position and active TUNE. i S L 6
Vehicle Speed in MPH or KPH. Sl it i sl
Engine Speed in RPM. i 0 )
MAP: Manifold Absolute Pressure in PSIA or KPA. TPS i
TPS: Throttle position displayed in percentage. ENGINE TIMING 0.0 | dBTDC
Engine Timing in degrees BTDC BATTERY 02 | vOLTS
(B:a“fryt\{;_)'tage 'ntV0|t$- CorF COOLANT TEMPERATURE | 150 | DEGC
oolant Temperature in °C or °F. FUEL TRIM 00 | %
Fuel Trim: Change to OE pulse width in %.
o o TIMING ADWANCE 00 | DEGREES
Timing Advance: Change to OE ignition timing in degrees. o e

Fuel Duty: Percentage of injector on time.

All Monitor items can also be viewed as a gage by selecting

the gage tab.

FACTORY PRESET TUNES

Figure 10 Monitor Items.

The Teryx Charge Fl has 4 locked calibrations. The remaining 6 positions (4-9) are for calibrations
that can be modified through a PC with the MSDView software.

The following are brief descriptions of each calibration.

0 - Valet - 25 mph (Locked)
1 - Stock (Locked)
2 - Stock Enhanced, 8,000 rpm and 56 mph - (Locked)

3. Stock Enhanced with Pipes, 8,200 rpm and 58 mph - (Locked)
4. Stock Enhanced, default (Same as Tune 2, User configurable
5. Stock Enhanced, default (Same as Tune 2, User configurable

8
9

. Stock Enhanced, default (Same as Tune 2, User configurable

|

6. Stock Enhanced, default (Same as Tune 2, User configurable)
)

)

. Stock Enhanced, default (Same as Tune 2, User configurable)

E

7. Stock Enhanced, default (Same as Tune 2, User configurable
(
(
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6 INSTALLATION INSTRUCTIONS

TABLE EDITING
To update cells in the Advance or Fuel tables,
highlight one or more cells, type the new value and
hit enter (Figure 11).

ENGINE SPEED  RPM
0 | 1000 = 2000 @ 3000 4000 @ SOO0 @ GOOOD @ 7000 @ 8000 @ 9000

Right-clicking the highlighted cells will give the
option to offset, scale, or to copy the highlighted
cells (Figure 12).

MAP PSIA,

Offset: Increments the selected cells value by the
new value.

For example, if the value in the selected cell is 2,
offsetting by 1 will change the cell to 3 (2+1=3).

Figure 11 Select Cells.

Scale: This option will multiply selected cells by the
value entered.

Note: Cell values will be clamped to their minimum ENGINE SPEED_RPM
or max'mum range default |fthe Oﬁset or Scale 0 1000 | 2000 @ 3000 @ 4000 S000 @ 6OOO @ 7000 @ 8000 @ S000
output values exceed the cell range. wso o ‘ 0 ‘ 0 ‘ 0 ‘ 0 ‘ 0 ‘ S

Copy: Values can be copied and pasted into other
Tune tables.

MSDVIEW SOFTWARE TIPS AND HINTS
UNITS (Metric/English)

To toggle between English and metric units select
“View > Units’, then make a selection.

SAVING AND OPENING FILES

MSDView can save files with all settings on the local
drive. These files can be viewed, edited, emailed or
transferred to a different controller at a later time. To
save all current settings, select ‘File > Save As...’, type in the new file name and press ‘Save’. To view, edit
or transfer settings to a different controller select ‘File >Open’.

Figure 12 Edit Options.

RESTORING DEFAULT VALUES
To restore all values select ‘Edit>Default’. Restoring default values will overwrite all settings in the controller
to their original default values.

TEXT SIZES
A range of text sizes from ‘Largest’ to ‘Smallest’ can be chosen by selecting ‘View>Text Size’ from the
menu bar.
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INSTALLATION INSTRUCTIONS 7

TECH NOTES
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MSD

POWER
SPORTS

TECH NOTES

Service

In case of malfunction, this MSD component will be repaired free of charge according to the terms of the warranty.
When returning MSD components for warranty service, Proof of Purchase must be supplied for verification. After
the warranty period has expired, repair service is based on a minimum and maximum fee.

All returns must have a Return Material Authorization (RMA) number issued to them before
being returned. To obtain an RMA number please contact MSD Customer Service at 1 (888) MSD-7859 or visit
our website at www.msdperformance.com/rma to automatically obtain a number and shipping information.

When returning the unit for repair, leave all wires at the length in which you have them installed. Be sure to include
adetailed account of any problems experienced, and what components and accessories are installed on the vehicle.
The repaired unit will be returned as soon as possible using Ground shipping methods (ground shipping is covered
by warranty). For more information, call MSD at (915) 855-7123. MSD technicians are available from 7:00 a.m. to
5:00 p.m. Monday - Friday (mountain time).

Limited Warranty

MSD warrants this product to be free from defects in material and workmanship under its intended normal use*,
when properly installed and purchased from an authorized MSD dealer, for a period of one year from the date of
the original purchase. This warranty is void for any products purchased through auction websites. If found to be
defective as mentioned above, it will be repaired or replaced at the option of MSD. Any item that is covered under
this warranty will be returned free of charge using Ground shipping methods.

This shall constitute the sole remedy of the purchaser and the sole liability of MSD. To the extent permitted by
law, the foregoing is exclusive and in lieu of all other warranties or representation whether expressed or implied,
including any implied warranty of merchantability or fitness. In no event shall MSD or its suppliers be liable for special
or consequential damages.

*Intended normal use means that this item is being used as was originally intended and for the original application
as sold by MSD. Any modifications to this item or if it is used on an application other than what MSD markets the
product, the warranty will be void. It is the sole responsibility of the customer to determine that this item will work for
the application they are intending. MSD will accept no liability for custom applications.
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